Statistics slowdown

Incident Report for Short.io

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 12:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2025 - 08:58 UTC

Identified

Due to emergency maintenance requests to statistics produce timeouts
Posted Apr 21, 2025 - 08:14 UTC
This incident affected: Link statistics.