EU links replication delay

Incident Report for Short.io

Resolved

This incident has been resolved.
Posted Mar 17, 2019 - 14:51 UTC

Investigating

We need more time to sync links in EU. New links, will not be available if you use Short.cm from EU
Posted Mar 17, 2019 - 14:30 UTC
This incident affected: URL redirector.