Bulk Edit Spreadsheets outage
Incident Report for Short.io
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 11:28 UTC
Investigating
We are currently investigating this issue.
Posted Sep 27, 2024 - 10:49 UTC
This incident affected: API.