Broken dashboard

Incident Report for Short.io

Resolved

This incident has been resolved.
Posted Jul 27, 2016 - 07:50 UTC

Investigating

We are currently investigating this issue.
Posted Jul 27, 2016 - 07:47 UTC