DDoS Attack, affected redirects
Incident Report for Short.io
Postmortem

Following a series of Distributed Denial of Service (DDoS) attacks on our network infrastructure, our development team conducted an extensive review and identified the lack of adequate DDoS protection as a significant vulnerability. These attacks severely impacted our service availability, affecting both client trust and operational performance.

Issue Description

The attacks utilized a high volume of requests to overwhelm our system, making it inaccessible to legitimate users. Traditional mitigation strategies proved insufficient against the scale and sophistication of these attacks.

Resolution Development

In response to this challenge, the development team proposed the integration of a Proof-of-Work (PoW) algorithm to bolster our defenses against DDoS attacks. PoW requires a not-insignificant amount of computational work from the requester, thus providing a natural barrier against the bulk automated requests typical of DDoS attacks.

Implementation Strategy

The chosen PoW algorithm will require all incoming requests to provide a proof of computational effort before processing. This method is expected to deter malicious actors due to the increased costs and effort associated with launching a DDoS attack.

Posted Apr 08, 2024 - 22:33 UTC

Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 22:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2024 - 22:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 08, 2024 - 22:29 UTC
Investigating
We are currently investigating this issue.
Posted Apr 08, 2024 - 22:15 UTC
This incident affected: URL redirector.